paisley 0.1.4

Dart native
Flutter Android iOS

SPA engine that sends HTML to clients and handles events via WebSocket.

1
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Oct 29, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 42 API elements (45.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:paisley/paisley.dart that imports:
  • package:paisley/src/server/server.dart that imports:
  • package:paisley/src/server/angel.dart that imports:
  • package:web_socket_channel/io.dart that imports:
  • package:web_socket_channel/src/sink_completer.dart that imports:
  • package:web_socket_channel/src/channel.dart that imports:
  • package:web_socket_channel/src/_connect_html.dart that imports:
  • package:web_socket_channel/html.dart that imports:
  • package:stream_channel/stream_channel.dart that imports:
  • package:stream_channel/src/isolate_channel.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 25 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/core/rpc.g.dart:17:12

   ╷
17 │     return new Eval(script: script ?? this.script);
   │            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/core/rpc.g.dart

INFO: Unnecessary new keyword.

lib/src/core/rpc.g.dart:50:12

   ╷
50 │     return new Event(name: name ?? this.name, data: data ?? this.data);
   │            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/core/rpc.g.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-rc.02.1.12.1.1
angel_serialize^2.0.02.2.3+32.2.3+3
html_builder^1.0.01.0.51.0.5
http_parser^3.0.03.1.43.1.4
json_god^2.0.0-beta2.0.0-beta+32.0.0-beta+3
json_rpc_2^2.0.02.2.22.2.2
stream_channel^1.0.01.7.02.0.0
web_socket_channel^1.0.01.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
async-2.4.22.4.2
charcode-1.1.31.1.3
code_buffer-1.0.11.0.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.15.2.1
http2-1.0.11.0.1
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
matcher-0.12.90.12.9
merge_map-1.0.21.0.2
meta-1.2.31.2.3
mime-0.9.70.9.7
mock_request-1.0.71.0.7
path-1.7.01.7.0
quiver-2.1.4+12.1.4+1
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.0
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
uuid-2.2.22.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on stream_channel does not support the latest published version `2.0.0`

pubspec.yaml:15:19

   ╷
15 │   stream_channel: ^1.0.0
   │                   ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs