pageloader 3.3.0
pageloader: ^3.3.0 copied to clipboard

Dart native js
Flutter Android iOS web

Supports the creation of page objects that can be shared between in-browser tests and WebDriver tests.

1
likes
80 / 110
pub points
58 %
popularity

We analyzed this package on Jan 19, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 315 out of 555 API elements (56.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'type' is deprecated and shouldn't be used.

lib/src/generators/methods/annotation_evaluators.dart:54:37

   ╷
54 │     type = element.enclosingElement.type;
   │                                     ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generators/methods/annotation_evaluators.dart

INFO: 'type' is deprecated and shouldn't be used.

lib/src/generators/methods/annotation_evaluators.dart:57:20

   ╷
57 │     type = element.type;
   │                    ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generators/methods/annotation_evaluators.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.36.0 <0.40.00.39.170.41.2
build>0.12.7 <2.0.01.6.11.6.1
build_config>=0.3.1 <5.0.00.4.50.4.5
built_value^7.0.07.1.07.1.0
matcher^0.12.0+10.12.90.12.9
quiver>=2.0.0 <3.0.02.1.52.1.5
source_gen^0.9.1+30.9.10+10.9.10+1
webdriver^2.1.02.1.22.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.014.0.0
archive-2.0.132.0.13
args-1.6.01.6.0
async-2.4.22.4.2
built_collection-4.3.24.3.2
charcode-1.1.31.1.3
checked_yaml-1.0.41.0.4
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.11
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.13.1.1
logging-0.11.40.11.4
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
pubspec_parse-0.1.70.1.7
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
sync_http-0.2.00.2.0
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.36.0 <0.40.0` on analyzer does not support the latest published version `0.41.2`

pubspec.yaml:20:13

   ╷
20 │   analyzer: '>=0.36.0 <0.40.0'
   │             ^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs