package_info_plus_windows 1.0.1
package_info_plus_windows: ^1.0.1 copied to clipboard

Windows implementation of the package_info_plus plugin

1
likes
100 / 130
pub points
97 %
popularity

We analyzed this package on May 7, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 4 API elements (50.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/file_version_info.dart:20:7

   ╷
20 │ final _GetUserDefaultLangID = _kernel32
   │       ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/file_version_info.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^1.0.01.0.01.0.0
flutterflutter0.0.00.0.0
package_info_plus_platform_interface^1.0.01.0.11.0.1
win32^2.0.02.0.52.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.