package_info_plus_web 0.1.0
package_info_plus_web: ^0.1.0

Flutter web

Web platform implementation of package_info_plus

0
likes
70 / 110
pub points
83 %
popularity

We analyzed this package on Nov 21, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 5 API elements (60.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:package_info_plus_web/package_info_plus_web.dart that declares support for platforms: Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.00.12.20.12.2
meta^1.1.71.3.0-nullsafety.61.3.0-nullsafety.6
package_info_plus_platform_interface^0.1.00.1.00.1.0
platform_detect^1.4.01.4.01.4.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
http_parser-3.1.43.1.4
js-0.6.3-nullsafety.30.6.3-nullsafety.3
path-1.7.01.8.0-nullsafety.3
plugin_platform_interface-1.0.31.0.3
pub_semver-1.4.41.4.4
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs