opus_dart 1.0.3
opus_dart: ^1.0.3

Dart native
Flutter Android iOS

Wraps libopus in dart, and additionally provides a dart friendly API for encoding and decoding

1
likes
90 / 110
pub points
50 %
popularity

We analyzed this package on Nov 20, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 235 out of 315 API elements (74.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:opus_dart/opus_dart.dart that imports:
  • package:opus_dart/src/opus_dart_streaming.dart that imports:
  • package:opus_dart/src/opus_dart_misc.dart that imports:
  • package:opus_dart/wrappers/opus_decoder.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/allocation.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Avoid const keyword.

lib/src/opus_dart_encoder.dart:344:49

    ╷
344 │   const Map<Application, int> _applicationCodes = const <Application, int>{
    │ ┌─────────────────────────────────────────────────^
345 │ │   Application.voip: opus_defines.OPUS_APPLICATION_VOIP,
346 │ │   Application.audio: opus_defines.OPUS_APPLICATION_AUDIO,
347 │ │   Application.restrictedLowdely:
348 │ │       opus_defines.OPUS_APPLICATION_RESTRICTED_LOWDELAY
349 │ │ };
    │ └─^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/opus_dart_encoder.dart

lib/src/opus_dart_decoder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.30.1.3
meta^1.1.81.2.41.2.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
90
pub points
50%
popularity

Wraps libopus in dart, and additionally provides a dart friendly API for encoding and decoding

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

prokopwieler.hardundsoftware@gmail.com

License

BSD (LICENSE)

Dependencies

ffi, meta

More

Packages that depend on opus_dart