open_document 1.0.0
open_document: ^1.0.0 copied to clipboard

A new flutter plugin project.

2
likes
90 / 130
pub points
46 %
popularity

We analyzed this package on May 4, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 191 API elements (4.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:open_document/open_document.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Unused import: 'package:flutter/cupertino.dart'.

lib/open_document.dart:4:8

  ╷
4 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/open_document.dart

INFO: Unused import: 'package:path_provider_windows/path_provider_windows.dart'.

lib/open_document.dart:7:8

  ╷
7 │ import 'package:path_provider_windows/path_provider_windows.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/open_document.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.1.23.1.23.1.2
flutterflutter0.0.00.0.0
flutter_slidable^0.6.0-nullsafety.00.6.00.6.0
intl^0.17.00.17.00.17.0
path_provider_windows^2.0.02.0.12.0.1
share^2.0.12.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.0.01.0.0
meta-1.3.01.3.0
mime-1.0.01.0.0
path-1.8.01.8.0
path_provider_platform_interface-2.0.12.0.1
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.