olm 2.0.0
olm: ^2.0.0 copied to clipboard

Dart bindings for Olm, an implementation of the olm and megolm cryptographic ratchets

3
likes
100 / 130
pub points
70 %
popularity

We analyzed this package on May 4, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 108 API elements (2.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/src/common.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/ffi.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^1.0.01.0.01.0.0
js^0.6.30.6.30.6.3
test^1.16.51.17.31.17.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-21.0.021.0.0
analyzer-1.5.01.5.0
args-2.1.02.1.0
async-2.6.12.6.1
boolean_selector-2.1.02.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
file-6.1.06.1.0
frontend_server_client-2.1.02.1.0
glob-2.0.12.0.1
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.01.0.0
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_preamble-2.0.02.0.0
package_config-2.0.02.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
shelf-1.1.11.1.1
shelf_packages_handler-3.0.03.0.0
shelf_static-1.0.01.0.0
shelf_web_socket-1.0.11.0.1
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.4.00.4.0
test_core-0.3.230.3.23
typed_data-1.3.01.3.0
vm_service-6.2.06.2.0
watcher-1.0.01.0.0
web_socket_channel-2.1.02.1.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Dart 2.12.4.

3
likes
100
pub points
70%
popularity

Publisher

famedly.com

Dart bindings for Olm, an implementation of the olm and megolm cryptographic ratchets

Homepage
Repository (GitLab)
View/report issues

Documentation

API reference

License

AGPL 3.0 (LICENSE)

Dependencies

ffi, js, test

More

Packages that depend on olm