ogurets_flutter 2.0.0
ogurets_flutter: ^2.0.0 copied to clipboard

This package extends the Cucumber based Ogurets package to allow to support Flutter.

7
likes
60/ 130
pub points
40%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +83 ms] executing: uname -m
[  +40 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +6 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +9 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] 3595343e20a61ff16d14e8ecc25f364276bb1b8b
[        ] executing: [/tool/stable/flutter/] git tag --points-at 3595343e20a61ff16d14e8ecc25f364276bb1b8b
[  +16 ms] Exit code 0 from: git tag --points-at 3595343e20a61ff16d14e8ecc25f364276bb1b8b
[        ] 2.5.2
[  +12 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +8 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +68 ms] Unable to locate an Android SDK.
[   +5 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +6 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +63 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +12 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/pub upgrade --verbose
MSG : Resolving dependencies...
[+1902 ms] "flutter pub" took 2,001ms.
[   +3 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[        ] exiting with code 1

stderr: FINE: Pub 2.14.3
SLVR: fact: ogurets_flutter is 2.0.0
SLVR: derived: ogurets_flutter
SLVR: fact: ogurets_flutter depends on commandline_splitter ^1.5.2
SLVR: fact: ogurets_flutter depends on flutter any from sdk
SLVR: fact: ogurets_flutter depends on flutter_driver any from sdk
SLVR: fact: ogurets_flutter depends on image ^2.1.4
SLVR: fact: ogurets_flutter depends on logging ^0.11.3+2
SLVR: fact: ogurets_flutter depends on ogurets ^3.1.6
SLVR:   selecting ogurets_flutter
SLVR:   derived: ogurets ^3.1.6
SLVR:   derived: logging ^0.11.3+2
SLVR:   derived: image ^2.1.4
SLVR:   derived: flutter_driver any from sdk
SLVR:   derived: flutter any from sdk
SLVR:   derived: commandline_splitter ^1.5.2
IO  : Get versions from https://pub.dartlang.org/api/packages/commandline_splitter.
IO  : HTTP GET https://pub.dartlang.org/api/packages/commandline_splitter
    | Accept: application/vnd.pub.v2+json
    | user-agent: Dart pub 2.14.3
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:92:3)
           <asynchronous suspension>



Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_autorun.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because image >=2.1.14 <3.0.0-nullsafety.0 depends on archive ^2.0.0 and image >=2.0.4 <2.1.14 depends on archive >=1.0.16 <3.0.0, image >=2.0.4 <3.0.0-nullsafety.0 requires archive >=1.0.16 <3.0.0.
And because every version of flutter_driver from sdk depends on archive 3.1.2, flutter_driver from sdk is incompatible with image >=2.0.4 <3.0.0-nullsafety.0.
So, because ogurets_flutter depends on both flutter_driver any from sdk and image ^2.1.4, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

7
likes
60
pub points
40%
popularity

Publisher

bluebiscuitdesign.dev

This package extends the Cucumber based Ogurets package to allow to support Flutter.

Repository (GitHub)
View/report issues

License

BSD-2-Clause (LICENSE)

Dependencies

commandline_splitter, flutter, flutter_driver, image, logging, ogurets

More

Packages that depend on ogurets_flutter