ogurets_flutter 2.0.0
ogurets_flutter: ^2.0.0 copied to clipboard

This package extends the Cucumber based Ogurets package to allow to support Flutter.

2.0.0 #

  • move to nullsafe thanks to @nightscape

1.2.7 #

  • fixes some issues introduced from the previous build

1.2.6 #

  • updated method of adding in flutter extra run parameters as the command line library was chopping them off (tobindh@github.com)

1.2.5 #

  • documentation

1.2.4 #

  • last minute discovery that flutter driver sdk depends on lower version of image lib

1.2.3 #

  • Support for screen snapshotting
  • doesn't reset the app on first run

1.2.2 #

More robust detection of failures. Added OGURETS_FLUTTER_START_TIMEOUT.

1.2.1 #

Added in support for additional parameters for flutter build runs (flavours, device ids and generic additional parameters).

1.1.2 #

Added in override support for which file to actually run

1.1.1 #

This is the first release of ogurets_flutter. As per documentation.

7
likes
60
pub points
43%
popularity

Publisher

bluebiscuitdesign.dev

This package extends the Cucumber based Ogurets package to allow to support Flutter.

Repository (GitHub)
View/report issues

License

BSD-2-Clause (LICENSE)

Dependencies

commandline_splitter, flutter, flutter_driver, image, logging, ogurets

More

Packages that depend on ogurets_flutter