np8080 0.0.26

  • Readme
  • Changelog
  • Installing
  • 0

np8080 0.0.26 #

NP8080 is a simple notepad type app for the web with some text processing features. It is lightweight and fast to load. 100% functionality when offline so great for Chromebooks.

NP8080 Screenshot

I use it daily as a scratchpad, a markdown editor and for notes. Particularly handy when working in the context of a web browser as switching tabs is far smoother than switching applications.

You can try it out here.

Feature requests, bug reports and pull requests welcome!

Development Details #

NP8080 is written in Angular Dart and can be hosted on any web server as it is client-side. Find out more about Dart.

Build Status

Run tests with (note tests mostly moved to sub-packages):

  • pub run test -p chrome

Run in development with:

  • pub serve

Build for deployment with:

  • pub build --mode=release --output=build

Check source code formatting:

  • dartfmt -n .

Changelog

v0.0.26

  • Moved to Angular Dart 4.0.0 release.
  • Improved Reader view a) Removed dialog header and b) use theme border colour.
  • Added Numbering entry to Modify menu.
  • Fixed ordering of Manual content to match menu order.
  • Removed link to Notesboard 8080.

v0.0.25

  • Editing a document name can be confirmed by pressing return.
  • Selecting a timestamp can made by pressing return.
  • Improved theming of Menus.
  • Border of editor now matches theme.
  • More Unit tests.
  • Focus set on default dialog inputs.
  • Moved to Angular Dart Beta.

v0.0.24

  • Added normalise.css and reorganised CSS.
  • Updated About dialog to match Manual & Updated Welcome text.
  • Refactor textdocument class.
  • Menus now close afterclick on item rather than relying on MouseOut.
  • Added Split (by a specified delimiter) feature under modify.
  • Added Reader option to View menu.
  • Refactoring of 'component' name.

v0.0.23

  • Custom time/date format in Timestamp dialog.
  • Moved to Angular Dart 4 Alpha 1.
  • Can now Delete lines that do not contain a string.
  • Added Manual under Help menu.
  • Style updates.

v0.0.22

  • Moved to Angular Dart 4 Alpha.
  • Angular package import changed to 'angular'.
  • Persist markdown preview display on/off setting.
  • Dialogs refactored with common base class.
  • Styling updates to dialog headers.
  • Replace dialog non-modal and can be moved with buttons in header bar.
  • Replace dialog can insert a newline before the replace also.
  • Update pubspec for 'Dart 2.0' dev releases.
  • Added first shortcut [Ctrl-Q] to display Replace dialog.

v0.0.21

  • Moved to use minibus package for sending events.
  • Link to NB8080 added.
  • Preview for generate sequence added.
  • Timestamp is now a dialog with a selection of formats.

v0.0.20

  • Moved to use stringprocess package for all string operations.
  • No confirmation required for Start items if note is blank.
  • Dialogs now use Eventbus to trigger modal display.
  • Services now at the application level.
  • Restyle toolbar.

v0.0.19

  • Favicon updated.
  • HTML unencode.

v0.0.18

  • Styling updated for UI and Editor.
  • Generate can now add a new line after each string being repeated.
  • New advanced menu with the Uri Encode/Decode options.
  • Updated to AngularDart 3.1.0.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  np8080: ^0.0.26

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.2 <2.0.0-dev.infinity