minibus 1.0.1

Dart native js
Flutter Android iOS web

An easy to use minimal synchronous event bus to keep your application components decoupled and resusable.

minibus #

A library for a minimal synchronous event bus.

Basic Usage #

A simple usage example:

import 'package:minibus/minibus.dart';
String EVENT = "myevent";

main() {
  MiniBus bus1 = new MiniBus();
  bus1.subscribe(EVENT, (){print('Hello World!')});
  bus1.post(EVENT);
}

Features and bugs #

Please file feature requests and bugs.

Run tests with:

  • pub run test

Check source code formatting:

  • dartfmt -n .
0
likes
100
pub points
43%
popularity

An easy to use minimal synchronous event bus to keep your application components decoupled and resusable.

Repository (GitLab)
View/report issues

Documentation

API reference

Uploader

daftspaniel@gmail.com

License

BSD (LICENSE)

More

Packages that depend on minibus