This package is no longer maintained. #
Supports using Dartium during development for projects using Dart v1.
For projects using Dart v2, this package is no longer needed. See the Dart 2 migration guide for details.
The dart.js file is used in Dart browser apps to check for native Dart support and either (a) bootstrap Dartium or (b) load compiled JS instead.
Add the following to your pubspec.yaml:
dev_dependencies: browser: ^0.10.0
Run pub install.
Use a relative script tag in your html to the installed version:
If you do not wish to use pub, you may host a copy of this file locally instead. In this case, you will need to update it yourself as necessary. We reserve the right to move the old file in the repository, so we no longer recommend linking to it directly.
This script was required for dart:js interop to work, but it is no longer needed. The functionality is now supported by dart:js directly.
If you previously had a script such as this, please remove it:
- Deprecating package. No functional update.
0.10.0+2 - Mar 18, 2014 #
- Last functional update.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: browser: ^0.10.0+3
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
This package is not analyzed, because it is discontinued.
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
|Dart SDK||>=1.8.0 <2.0.0|