nineold 3.1.0
nineold: ^3.1.0 copied to clipboard

Nineoldwidget is a component used to encapsulate the nine palace display of pictures.

3
likes
65/ 130
pub points
41%
popularity

We analyzed this package 38 hours ago, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 44 API elements (6.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:nineold/loader/image_with_loader.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/nine_old_frame.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/widget/nine_old_widget.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.1.03.2.03.2.0
flutterflutter0.0.00.0.0
photo_view^0.12.00.12.00.13.0
transparent_image^2.0.02.0.02.0.0
uuid^3.0.43.0.53.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
meta-1.7.01.7.0
octo_image-1.0.11.0.1
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
rxdart-0.27.30.27.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.12.0.1
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on photo_view does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

3
likes
65
pub points
41%
popularity

Nineoldwidget is a component used to encapsulate the nine palace display of pictures.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cached_network_image, flutter, photo_view, transparent_image, uuid

More

Packages that depend on nineold