nim_core 1.0.0-rc.20
nim_core: ^1.0.0-rc.20 copied to clipboard

A Flutter plugin for NetEase IM SDK on Android, iOS and Windows.

1
likes
110/ 130
pub points
66%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 243 out of 314 API elements (77.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:nim_core/nim_core.dart that declares support for platforms: Android, iOS, Windows, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

lib/nim_core.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/chatroom/chatroom_service.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
nim_core_macos^1.0.0-rc.191.0.0-rc.191.0.0-rc.19
nim_core_platform_interface^1.0.0-rc.191.0.0-rc.191.0.0-rc.19
nim_core_windows^1.0.0-rc.191.0.0-rc.191.0.0-rc.19
path_provider^2.0.22.0.72.0.7
yunxin_alog^1.0.7-rc.11.0.7-rc.11.0.7-rc.1
yunxin_base^0.1.0-rc.00.1.0-rc.00.1.0-rc.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
args-2.3.02.3.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
intl-0.17.00.17.0
json_annotation-4.0.14.4.0
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
process_run-0.12.2+20.12.2+2
pub_semver-2.1.02.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.