network_info_plus 1.0.1
network_info_plus: ^1.0.1 copied to clipboard

Flutter plugin for discovering information (e.g. WiFi details) of the network.

25
likes
130 / 130
pub points
86 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 8 API elements (87.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:network_info_plus/network_info_plus.dart that imports:
  • package:network_info_plus_linux/network_info_plus_linux.dart that declares support for platforms: Linux
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.3.01.3.01.4.0
network_info_plus_linux^1.0.01.0.21.0.2
network_info_plus_macos^1.0.01.0.11.0.1
network_info_plus_platform_interface^1.0.01.0.11.0.1
network_info_plus_web^1.0.01.0.11.0.1
network_info_plus_windows^1.0.01.0.21.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.1.12.1.1
characters-1.1.01.1.0
collection-1.15.01.15.0
dbus-0.5.20.5.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
petitparser-4.1.04.2.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
xml-5.1.25.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.