native_pdf_view 4.2.0
native_pdf_view: ^4.2.0 copied to clipboard

Flutter plugin to render PDF files on Web, MacOS, Windows, Android and iOS.

282
likes
130/ 130
pub points
97%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 30 out of 43 API elements (69.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Linux`.

Because:

  • package:native_pdf_view/native_pdf_view.dart that imports:
  • package:native_pdf_view/src/native_pdf_view.dart that imports:
  • package:native_pdf_renderer/native_pdf_renderer.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
native_pdf_renderer^3.1.03.1.03.1.0
photo_view^0.12.00.12.00.13.0
synchronized^3.0.03.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
characters-1.1.01.2.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
device_info-2.0.22.0.2
device_info_platform_interface-2.0.12.0.1
extension-0.2.00.2.0
flutter_web_plugins-0.0.00.0.0
image-3.0.83.0.8
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
petitparser-4.4.04.4.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on photo_view does not support the stable version `0.13.0`, that was published 16 days ago.

When photo_view is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

282
likes
130
pub points
97%
popularity

Publisher

serge.software

Flutter plugin to render PDF files on Web, MacOS, Windows, Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, native_pdf_renderer, photo_view, synchronized

More

Packages that depend on native_pdf_view