native_pdf_renderer 5.0.0+1 copy "native_pdf_renderer: ^5.0.0+1" to clipboard
native_pdf_renderer: ^5.0.0+1 copied to clipboard

Flutter plugin to render PDF pages as images on Web, MacOS, Windows, Android and iOS.

104
likes
140/ 160
pub points
89%
popularity

We analyzed this package 9 hours ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/rbcprolabs/packages.flutter/tree/master/packages/native_pdf_renderer was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/rbcprolabs/packages.flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+native_pdf_renderer%22 was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: native_pdf_renderer,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: native_pdf_renderer.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

228 out of 285 API elements (80.0 %) have documentation comments.

Some symbols that are missing documentation: native_pdf_renderer, native_pdf_renderer.PDFViewPageBuilder, native_pdf_renderer.PDFViewPageRenderer, native_pdf_renderer.PdfController.dispose, native_pdf_renderer.PdfControllerPinch.page.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:native_pdf_renderer/native_pdf_renderer.dart that imports:
  • package:pdfx/pdfx.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:native_pdf_renderer/native_pdf_renderer.dart that imports:
  • package:pdfx/pdfx.dart that imports:
  • package:pdfx/src/viewer/simple/pdf_view.dart that imports:
  • package:pdfx/src/renderer/has_pdf_support.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
pdfx ^1.0.1 1.0.1+1 2.6.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
device_info_plus - 3.2.4 10.1.0
device_info_plus_linux - 2.1.1 5.0.0
device_info_plus_macos - 2.2.3 5.0.0
device_info_plus_platform_interface - 2.6.1 7.0.0
device_info_plus_web - 2.1.0 5.0.0
device_info_plus_windows - 2.1.1 6.0.0
extension - 0.2.0 0.6.0
ffi - 1.2.1 2.1.2
file - 6.1.4 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
photo_view - 0.13.0 0.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
synchronized - 3.1.0+1 3.1.0+1
typed_data - 1.3.2 1.3.2
universal_platform - 1.1.0 1.1.0
uuid - 3.0.7 4.4.2
vector_math - 2.1.4 2.1.4
win32 - 2.6.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on pdfx does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions pdfx to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

104
likes
140
pub points
89%
popularity

Publisher

verified publisherserge.software

Flutter plugin to render PDF pages as images on Web, MacOS, Windows, Android and iOS.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter, pdfx

More

Packages that depend on native_pdf_renderer