my_device 0.0.8 icon indicating copy to clipboard operation
my_device: ^0.0.8 copied to clipboard

Agile and easy access to device information and internet connection alerts

4
likes
130/ 130
pub points
22%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 30 out of 33 API elements (90.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:my_device/my_device.dart that imports:
  • package:my_device/src/device.dart that imports:
  • package:handy_dialogs/handy_dialogs.dart that imports:
  • package:handy_dialogs/src/navigation.dart that imports:
  • package:sound_library/sound_library.dart that imports:
  • package:sound_library/src/sound_library.dart that imports:
  • package:storage_manager/storage_manager.dart that imports:
  • package:storage_manager/src/firestorage.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:my_device/my_device.dart that imports:
  • package:my_device/src/device.dart that imports:
  • package:handy_dialogs/handy_dialogs.dart that imports:
  • package:handy_dialogs/src/navigation.dart that imports:
  • package:sound_library/sound_library.dart that imports:
  • package:sound_library/src/sound_library.dart that imports:
  • package:storage_manager/storage_manager.dart that imports:
  • package:storage_manager/src/firestorage.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:my_device/my_device.dart that imports:
  • package:my_device/src/device.dart that imports:
  • package:handy_dialogs/handy_dialogs.dart that imports:
  • package:handy_dialogs/src/navigation.dart that imports:
  • package:sound_library/sound_library.dart that imports:
  • package:sound_library/src/sound_library.dart that imports:
  • package:storage_manager/storage_manager.dart that imports:
  • package:storage_manager/src/firestorage.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Web`.

Because:

  • package:my_device/my_device.dart that imports:
  • package:my_device/src/device.dart that imports:
  • package:handy_dialogs/handy_dialogs.dart that imports:
  • package:handy_dialogs/src/navigation.dart that imports:
  • package:sound_library/sound_library.dart that imports:
  • package:sound_library/src/sound_library.dart that imports:
  • package:audioplayers/audioplayers.dart that imports:
  • package:audioplayers/src/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity_plus^2.2.12.3.52.3.5
device_info_plus^3.2.23.2.44.0.0
flutterflutter0.0.00.0.0
handy_dialogs^0.0.50.0.50.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.12.3.1
async-2.9.02.9.0
audioplayers-0.20.11.0.1
characters-1.2.01.2.1
collection-1.16.01.16.0
connectivity_plus_linux-1.3.11.3.1
connectivity_plus_macos-1.2.41.2.4
connectivity_plus_platform_interface-1.2.11.2.1
connectivity_plus_web-1.2.21.2.2
connectivity_plus_windows-1.2.21.2.2
cross_file-0.3.3+10.3.3+1
crypto-3.0.23.0.2
dbus-0.7.40.7.5
device_info_plus_linux-2.1.12.1.1
device_info_plus_macos-2.2.32.2.3
device_info_plus_platform_interface-2.3.0+12.3.0+1
device_info_plus_web-2.1.02.1.0
device_info_plus_windows-2.1.13.0.0
ffi-1.2.12.0.1
file-6.1.26.1.2
firebase_core-1.18.01.18.0
firebase_core_platform_interface-4.4.14.4.1
firebase_core_web-1.6.51.6.5
firebase_storage-10.2.1810.2.18
firebase_storage_platform_interface-4.1.84.1.8
firebase_storage_web-3.2.173.2.17
flash-2.0.3+22.0.3+2
flutter_plugin_android_lifecycle-2.0.62.0.6
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.14.0.1
image_picker-0.8.5+30.8.5+3
image_picker_android-0.8.5+10.8.5+1
image_picker_for_web-2.1.82.1.8
image_picker_ios-0.8.5+50.8.5+5
image_picker_platform_interface-2.5.02.5.0
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
nm-0.5.00.5.0
path-1.8.21.8.2
path_provider-2.0.112.0.11
path_provider_android-2.0.152.0.15
path_provider_ios-2.0.102.0.10
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.42.0.4
path_provider_windows-2.0.72.1.0
petitparser-5.0.05.0.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
shared_preferences-2.0.152.0.15
shared_preferences_android-2.0.122.0.12
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
sound_library-0.1.10.1.1
source_span-1.9.01.9.0
storage_manager-0.1.100.1.10
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-3.0.63.0.6
vector_math-2.1.22.1.2
win32-2.6.12.7.0
xdg_directories-0.2.0+10.2.0+1
xml-6.1.06.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.2.2` on device_info_plus does not support the stable version `4.0.0`, that was published 3 days ago.

When device_info_plus is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

4
likes
130
pub points
22%
popularity

Publisher

verified publisher iconmisdevelop.app

Agile and easy access to device information and internet connection alerts

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

connectivity_plus, device_info_plus, flutter, handy_dialogs

More

Packages that depend on my_device