moronepo 0.1.3

Flutter Android iOS

A tool to simplify development in a dart multi-package repository.

3
likes
70 / 110
pub points
45 %
popularity

We analyzed this package on Oct 15, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 25 API elements (24.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:moronepo/moronepo.dart that imports:
  • package:moronepo/src/project_finder/project_finder.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: Avoid using braces in interpolation when not needed.

lib/src/command/update_flutter_sdk_command.dart:48:32

   ╷
48 │         print("Flutter version ${currentVersion} within ${versionConstraint}. No need to update.");
   │                                ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/command/update_flutter_sdk_command.dart

INFO: Avoid using braces in interpolation when not needed.

lib/src/command/update_flutter_sdk_command.dart:48:57

   ╷
48 │         print("Flutter version ${currentVersion} within ${versionConstraint}. No need to update.");
   │                                                         ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/command/update_flutter_sdk_command.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
The current Dart SDK version is 2.10.2.

Because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0 and test_api >=0.2.19-nullsafety.2 depends on boolean_selector >=2.1.0-nullsafety <2.1.0, test >=1.3.0 <1.12.0 is incompatible with test_api >=0.2.19-nullsafety.2.
And because test >=1.15.3 <1.16.0-nullsafety depends on test_api 0.2.18 and test >=1.15.0 <1.15.3 depends on test_api 0.2.17, test_api >=0.2.19-nullsafety.2 is incompatible with test >=1.3.0 <1.12.0-∞ or >=1.15.0 <1.16.0-nullsafety.
And because test >=1.14.5 <1.15.0 depends on test_api 0.2.16 and test >=1.13.0 <1.14.5 depends on test_api 0.2.15, test_api >=0.2.19-nullsafety.2 is incompatible with test >=1.3.0 <1.12.0-∞ or >=1.13.0 <1.16.0-nullsafety.
And because test >=1.12.0 <1.13.0 depends on test_api 0.2.14 and every version of flutter_test from sdk depends on test_api 0.2.19-nullsafety.2, flutter_test from sdk is incompatible with test >=1.3.0 <1.16.0-nullsafety.
And because test >=1.16.0-nullsafety <1.16.0-nullsafety.5 requires SDK version >=2.10.0-0 <2.10.0 and test >=1.16.0-nullsafety.5 depends on test_core 0.3.12-nullsafety.5, if flutter_test any from sdk and test >=1.3.0 then test_core 0.3.12-nullsafety.5.
Because test_core >=0.3.12-nullsafety.5 depends on analyzer >=0.39.5 <0.41.0 and json_serializable >=2.1.1 <3.1.0 depends on analyzer >=0.33.3 <0.37.0, test_core >=0.3.12-nullsafety.5 is incompatible with json_serializable >=2.1.1 <3.1.0.
Thus, one of flutter_test any from sdk or test >=1.3.0 or json_serializable >=2.1.1 <3.1.0 must be false.
And because moronepo depends on flutter_test any from sdk, test >=1.3.0 is incompatible with json_serializable >=2.1.1 <3.1.0.
So, because moronepo depends on both json_serializable ^2.3.0 and test ^1.6.3, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
70
pub points
45%
popularity

Publisher

meniga.com

A tool to simplify development in a dart multi-package repository.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

args, equatable, flutter, glob, json_annotation, logging, meta, path, pub_semver, pubspec_parse, quiver

More

Packages that depend on moronepo