moronepo 0.1.1

  • Readme
  • Changelog
  • Installing
  • 46

moronepo #

pub package Build Status codecov

A tool to simplify development in a dart multi-package repository.

Currently, it supports following commands:

print command

run command

update-flutter-sdk command

Usage #

Activate moronepo:

pub global activate moronepo

or prepend each command with flutter if used:

flutter pub global activate moronepo

Now it should be possible to run moronepo:

pub global run moronepo [--filter <filter>] [--project <name>] [--working-directory <path>] <command>

where filter is a comma-separated list of filters hasTests,isFlutter,isRoot. Each filter can be negated by preceding it with a !, for example !isFlutter.

You can also follow how to set up a global command
to make it available as a regular shell command by appending PATH.

moronepo print

or creating an alias instead:

alias moronepo="flutter pub global run moronepo"

moronepo print
moronepo print

run command #

moronepo run <command>

For example:

moronepo run pub get

update-flutter-sdk command #

Specifying environment.flutter in pubspec.yaml:

name: project
environment:
  flutter: ">=1.10.0 <1.11.0"

and then running:

moronepo update-flutter-sdk

forces an update to the Flutter SDK to the latest version within those constraints.

0.1.1 #

  • Add update-flutter-sdk command
  • Add --filter option to filter out projects

0.1.0 #

  • Add print command
  • Add run command

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate moronepo

2. Use it

The package has the following executables:


$ moronepo

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  moronepo: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:moronepo/moronepo.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Apr 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

1 out of 1 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/command/update_flutter_sdk_command.dart. (-1.49 points)

Analysis of lib/src/command/update_flutter_sdk_command.dart reported 3 hints:

line 45 col 32: Avoid using braces in interpolation when not needed.

line 45 col 57: Avoid using braces in interpolation when not needed.

line 50 col 40: Avoid using braces in interpolation when not needed.

Fix lib/src/project_finder/project_finder.dart. (-0.50 points)

Analysis of lib/src/project_finder/project_finder.dart reported 1 hint:

line 47 col 41: Avoid using braces in interpolation when not needed.

Format lib/src/command/command_and_arguments_formatter.dart.

Run flutter format to format lib/src/command/command_and_arguments_formatter.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/command/print_command.dart (Run flutter format to format lib/src/command/print_command.dart.)
  • lib/src/command/run_command.dart (Run flutter format to format lib/src/command/run_command.dart.)
  • lib/src/options_setter.dart (Run flutter format to format lib/src/options_setter.dart.)
  • lib/src/project_finder/project.dart (Run flutter format to format lib/src/project_finder/project.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (json_annotation).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and moronepo.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
args ^1.5.2 1.6.0
equatable ^1.1.1 1.1.1
flutter 0.0.0
glob ^1.2.0 1.2.0
json_annotation ^2.3.0 2.4.0 3.0.1
logging ^0.11.4 0.11.4
meta ^1.1.7 1.1.8
path ^1.6.4 1.6.4
pub_semver ^1.4.4 1.4.4
pubspec_parse ^0.1.5 0.1.5
quiver ^2.0.0 2.1.3
Transitive dependencies
async 2.4.1
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.11 1.14.12
js 0.6.1+1
node_interop 1.0.3
node_io 1.0.1+2
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
yaml 2.2.0
Dev dependencies
build_runner ^1.7.1
flutter_test
json_serializable ^2.3.0
matcher ^0.12.5 0.12.6
mockito ^4.1.1
pedantic ^1.8.0+1 1.9.0
test ^1.6.3