more_widgets 3.1.6 copy "more_widgets: ^3.1.6" to clipboard
more_widgets: ^3.1.6 copied to clipboard

This package will offer you new useful widgets to use in your apps.

5
likes
120/ 140
pub points
47%
popularity

We analyzed this package 5 hours ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

20 out of 43 API elements (46.5 %) have documentation comments.

Some symbols that are missing documentation: more_widgets, more_widgets.DefaultAction, more_widgets.DefaultAction.DefaultAction, more_widgets.DestructiveAction, more_widgets.DestructiveAction.DestructiveAction.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:more_widgets/more_widgets.dart that imports:
  • package:more_widgets/src/loading_widget.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/src/dialogs/dialog_with_options.dart:1:1

  ╷
1 │ /// Copyright 2023, simonbraillard
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dialogs/dialog_with_options.dart

INFO: Dangling library doc comment.

lib/src/dialogs/dialogs.dart:1:1

  ╷
1 │ /// Copyright 2023, Simon Braillard
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dialogs/dialogs.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

5
likes
120
pub points
47%
popularity

Publisher

unverified uploader

This package will offer you new useful widgets to use in your apps.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on more_widgets