moor_generator 4.1.0 icon indicating copy to clipboard operation
moor_generator: ^4.1.0 copied to clipboard

Dev-dependency to generate table and dataclasses together with the moor package.

52
likes
30/ 120
pub points
92%
popularity

We analyzed this package 2 days ago, and awarded it 30 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 10icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:moor_generator/moor_generator.dart that imports:
  • package:moor_generator/src/model/model.dart that imports:
  • package:moor_generator/src/model/view.dart that imports:
  • package:moor_generator/src/model/declarations/declaration.dart that imports:
  • package:moor_generator/src/model/sources.dart that imports:
  • package:moor_generator/src/analyzer/runner/file_graph.dart that imports:
  • package:moor_generator/src/analyzer/errors.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:moor_generator/moor_generator.dart that imports:
  • package:moor_generator/src/model/model.dart that imports:
  • package:moor_generator/src/model/view.dart that imports:
  • package:moor_generator/src/model/declarations/declaration.dart that imports:
  • package:moor_generator/src/model/sources.dart that imports:
  • package:moor_generator/src/analyzer/runner/file_graph.dart that imports:
  • package:moor_generator/src/analyzer/errors.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:moor_generator/moor_generator.dart that imports:
  • package:moor_generator/src/model/model.dart that imports:
  • package:moor_generator/src/model/view.dart that imports:
  • package:moor_generator/src/model/declarations/declaration.dart that imports:
  • package:moor_generator/src/model/sources.dart that imports:
  • package:moor_generator/src/analyzer/runner/file_graph.dart that imports:
  • package:moor_generator/src/analyzer/errors.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:moor_generator/moor_generator.dart that imports:
  • package:moor_generator/src/model/model.dart that imports:
  • package:moor_generator/src/model/view.dart that imports:
  • package:moor_generator/src/model/declarations/declaration.dart that imports:
  • package:moor_generator/src/model/sources.dart that imports:
  • package:moor_generator/src/analyzer/runner/file_graph.dart that imports:
  • package:moor_generator/src/analyzer/errors.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:moor_generator/moor_generator.dart that imports:
  • package:moor_generator/src/model/model.dart that imports:
  • package:moor_generator/src/model/view.dart that imports:
  • package:moor_generator/src/model/declarations/declaration.dart that imports:
  • package:moor_generator/src/model/sources.dart that imports:
  • package:moor_generator/src/analyzer/runner/file_graph.dart that imports:
  • package:moor_generator/src/analyzer/errors.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:moor_generator/moor_generator.dart that imports:
  • package:moor_generator/src/model/model.dart that imports:
  • package:moor_generator/src/model/view.dart that imports:
  • package:moor_generator/src/model/declarations/declaration.dart that imports:
  • package:moor_generator/src/model/sources.dart that imports:
  • package:moor_generator/src/analyzer/runner/file_graph.dart that imports:
  • package:moor_generator/src/analyzer/errors.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 29 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:moor/src/runtime/executor/stream_queries.dart'.

lib/src/writer/database_writer.dart:3:8

  ╷
3 │ import 'package:moor/src/runtime/executor/stream_queries.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/writer/database_writer.dart

ERROR: The name 'AnyUpdateQuery' isn't defined, so it can't be used in an 'is' expression.

lib/src/writer/database_writer.dart:202:17

    ╷
202 │     if (this is AnyUpdateQuery) {
    │                 ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/writer/database_writer.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.40.0 <0.43.00.41.24.0.0
analyzer_plugin>=0.3.0 <0.5.00.4.00.10.0
args>=1.5.0 <3.0.02.3.12.3.1
build^1.6.01.6.22.3.0
build_config>=0.3.1 <1.0.00.4.71.0.0
build_resolvers^1.5.11.5.32.0.8
charcode^1.2.01.3.11.3.1
cli_util>=0.2.0 <0.4.00.3.50.3.5
collection^1.14.01.16.01.16.0
dart_style^1.3.31.3.122.2.3
json_annotation^4.0.04.5.04.5.0
logging>=0.11.0 <2.0.01.0.21.0.2
meta^1.1.01.7.01.7.0
moor^4.1.04.6.1+14.6.1+1
path^1.6.01.8.11.8.1
recase>=2.0.1 <5.0.04.0.04.0.0
source_gen^0.9.40.9.10+31.2.2
source_span^1.5.51.9.01.9.0
sqlite3>=0.1.6 <2.0.01.7.11.7.1
sqlparser^0.14.00.14.00.21.0
stream_transform>=0.1.0 <3.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.039.0.0
async-2.9.02.9.0
checked_yaml-1.0.42.0.1
convert-3.0.13.0.1
crypto-3.0.23.0.2
drift-1.6.01.6.0
ffi-1.2.11.2.1
file-6.1.26.1.2
glob-2.0.22.0.2
graphs-0.2.02.1.0
js-0.6.40.6.4
package_config-1.9.32.0.2
pedantic-1.11.11.11.1
pool-1.5.01.5.0
pub_semver-1.4.42.1.1
pubspec_parse-0.1.81.2.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
watcher-1.0.11.0.1
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `>=0.40.0 <0.43.0` on analyzer does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=0.3.0 <0.5.0` on analyzer_plugin does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions analyzer_plugin to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Dart 2.16.2.