moor_flutter 3.1.0
moor_flutter: ^3.1.0 copied to clipboard

Flutter Android iOS macOS

Flutter implementation of moor, a safe and reactive persistence library for Dart applications

207
likes
100 / 110
pub points
95 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 6 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:moor_flutter/moor_flutter.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.0.01.3.01.3.0
moor^3.0.03.4.04.1.0
path^1.0.01.8.01.8.0
sqflite^1.1.6+51.3.2+42.0.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
ffi-0.1.31.0.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
sqflite_common-1.0.3+12.0.0+1
sqlite3-0.1.81.0.0
synchronized-2.2.0+23.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on moor does not support the stable version `4.1.0`, that was published 10 days ago.

When moor is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions moor to update the constraint.

The constraint `^1.1.6+5` on sqflite does not support the stable version `2.0.0`, that was published 14 days ago.

When sqflite is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions sqflite to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

207
likes
100
pub points
95%
popularity

Publisher

simonbinder.eu

Flutter implementation of moor, a safe and reactive persistence library for Dart applications

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, meta, moor, path, sqflite

More

Packages that depend on moor_flutter