moon 0.0.3
moon: ^0.0.3 copied to clipboard

created to shine in the developer world giving the easiest and fastest way to build a flutter app!

10
likes
60/ 130
pub points
10%
popularity

We analyzed this package on Nov 28, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/boucoding/moon was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 53 out of 75 API elements (70.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:moon/moon.dart that imports:
  • package:share/share.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/utils/validator.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info^0.4.2+70.4.2+102.0.3
dio^3.0.103.0.104.0.4
file_picker^2.0.02.1.74.2.4
flutterflutter0.0.00.0.0
flutter_cache_manager^1.4.21.4.23.2.0
google_fonts^1.1.01.1.22.1.0
hive^1.4.41.4.4+12.0.4
package_info^0.4.30.4.3+42.0.2
platform_info^2.0.12.2.03.1.0
share^0.6.50.6.5+42.0.4
system_info^0.1.30.1.31.0.1
translator^0.1.50.1.50.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
device_info_platform_interface-1.0.12.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
file_utils-0.1.41.0.1
flutter_plugin_android_lifecycle-1.0.112.0.5
flutter_web_plugins-0.0.00.0.0
globbing-0.3.11.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
mime-0.9.71.0.1
path-1.8.01.8.0
path_provider-1.6.282.0.7
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
pedantic-1.11.11.11.1
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
rxdart-0.24.10.27.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+4
sqflite_common-1.0.3+32.0.1+1
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `^0.4.2+7` on device_info does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions device_info to update the constraint.

The constraint `^3.0.10` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

10
likes
60
pub points
10%
popularity

created to shine in the developer world giving the easiest and fastest way to build a flutter app!

Repository (missing)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

device_info, dio, file_picker, flutter, flutter_cache_manager, google_fonts, hive, package_info, platform_info, share, system_info, translator

More

Packages that depend on moon