midtrans_sdk 0.4.0 copy "midtrans_sdk: ^0.4.0" to clipboard
midtrans_sdk: ^0.4.0 copied to clipboard

A Flutter plugin for Midtrans Mobile SDK. Supports iOS and Android.

24
likes
130/ 140
pub points
80%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 42 API elements (2.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: midtrans_sdk, midtrans_sdk.ColorConverter, midtrans_sdk.ColorConverter.ColorConverter, midtrans_sdk.ColorConverter.fromJson, midtrans_sdk.ColorConverter.toJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:midtrans_sdk/midtrans_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:midtrans_sdk/midtrans_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:midtrans_sdk/midtrans_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:midtrans_sdk/midtrans_sdk.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
json_annotation ^4.8.1 4.8.1 4.8.1
json_serializable ^6.7.1 6.7.1 6.7.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_helper - 1.3.4 1.3.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

24
likes
130
pub points
80%
popularity

Publisher

verified publishertomykho.dev

A Flutter plugin for Midtrans Mobile SDK. Supports iOS and Android.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, json_annotation, json_serializable

More

Packages that depend on midtrans_sdk