media_tools 1.0.1+1 copy "media_tools: ^1.0.1+1" to clipboard
media_tools: ^1.0.1+1 copied to clipboard

A package that provide some functions to handle with media file

4
likes
130/ 140
pub points
30%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

7 out of 12 API elements (58.3 %) have documentation comments.

Some symbols that are missing documentation: media_tools, media_tools.AudioTools, media_tools.AudioTools.AudioTools, media_tools.VideoTools, media_tools.VideoTools.VideoTools.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:media_tools/media_tools.dart that imports:
  • package:media_tools/src/video_tools.dart that imports:
  • package:ffmpeg_kit_flutter_full/return_code.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:media_tools/media_tools.dart that imports:
  • package:media_tools/src/video_tools.dart that imports:
  • package:ffmpeg_kit_flutter_full/return_code.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:media_tools/media_tools.dart that imports:
  • package:media_tools/src/video_tools.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffmpeg_kit_flutter_full ^4.5.1 4.5.1 6.0.3
flutter flutter 0.0.0 0.0.0
path_provider ^2.0.11 2.1.3 2.1.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
ffmpeg_kit_flutter_platform_interface - 0.2.1 0.2.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.5.1` on ffmpeg_kit_flutter_full does not support the stable version `5.1.0`.

Try running dart pub upgrade --major-versions ffmpeg_kit_flutter_full to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

4
likes
130
pub points
30%
popularity

Publisher

verified publishersondv.dev

A package that provide some functions to handle with media file

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffmpeg_kit_flutter_full, flutter, path_provider

More

Packages that depend on media_tools