mailslurp 15.17.22 copy "mailslurp: ^15.17.22" to clipboard
mailslurp: ^15.17.22 copied to clipboard

MailSlurp

3
likes
120/ 160
pub points
18%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2849 out of 6169 API elements (46.2 %) have documentation comments.

Some symbols that are missing documentation: openapi.api, openapi.api.AbstractWebhookPayload, openapi.api.AbstractWebhookPayload.eventName, openapi.api.AbstractWebhookPayload.listFromJson, openapi.api.AbstractWebhookPayload.mapFromJson.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:mailslurp/api.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 545 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/api/alias_controller_api.dart:11:1

   ╷
11 │ part of openapi.api;
   │ ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/api/alias_controller_api.dart

INFO: The part-of directive uses a library name.

lib/api/attachment_controller_api.dart:11:1

   ╷
11 │ part of openapi.api;
   │ ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/api/attachment_controller_api.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http >=0.13.0 <0.14.0 0.13.6 1.2.2
intl ^0.17.0 0.17.0 0.19.0
meta ^1.1.8 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
clock - 1.1.1 1.1.1
collection - 1.19.0 1.19.0
http_parser - 4.1.0 4.1.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.13.0 <0.14.0` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.