mailer 3.2.1

Dart native
Flutter Android iOS

Compose and send emails from Dart. Supports file attachments and HTML emails

61
likes
80 / 110
pub points
96 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 111 API elements (23.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:mailer/mailer.dart that imports:
  • package:mailer/src/smtp/mail_sender.dart that imports:
  • package:mailer/src/smtp/smtp_client.dart that imports:
  • package:mailer/src/smtp/internal_representation/internal_representation.dart that imports:
  • package:mailer/src/entities/message.dart that imports:
  • package:mailer/src/entities/attachment.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/src/smtp/internal_representation/ir_header.dart:116:20

    ╷
116 │   const noCustom = const ['content-type', 'mime-version'];
    │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/smtp/internal_representation/ir_header.dart

INFO: Unnecessary new keyword.

lib/src/smtp/mail_sender.dart:12:24

   ╷
12 │ final Logger _logger = new Logger('mailer_sender');
   │                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/smtp/mail_sender.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async>=2.0.0 <3.0.02.4.22.4.2
intl>0.9.0 <1.0.00.16.10.16.1
logging>0.0.1 <1.0.00.11.40.11.4
mime>0.9.0 <1.0.00.9.70.9.7
path>0.9.0 <2.0.01.7.01.7.0
pedantic>=1.5.0 <2.0.01.9.21.9.2
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.14.131.14.13
meta-1.2.31.2.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs