magpie_cli 0.1.5
magpie_cli: ^0.1.5 copied to clipboard

Tools for magpie workflow, used to create template and start service.

1
likes
70 / 130
pub points
0 %
popularity

We analyzed this package on May 4, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:33:51

   ╷
33 │ <p>The browser should  have been opened instantly,<a href="http://127.0.0.1:8080">http://127.0.0.1:8080</a></p>
   │                                                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 24 API elements (20.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:magpie_cli/executable.dart that imports:
  • package:magpie_cli/src/runner/mpcli_command.dart that imports:
  • package:magpie_cli/src/reporting/reporting.dart that imports:
  • package:magpie_cli/src/version.dart that imports:
  • package:magpie_cli/src/globals.dart that imports:
  • package:magpie_cli/src/cache.dart that imports:
  • package:magpie_cli/src/base/platform.dart that imports:
  • package:magpie_cli/src/base/file_system.dart that imports:
  • package:magpie_cli/src/base/os.dart that imports:
  • package:magpie_cli/src/base/process_manager.dart that imports:
  • package:magpie_cli/src/base/process.dart that imports:
  • package:magpie_cli/src/base/utils.dart that imports:
  • package:magpie_cli/src/base/terminal.dart that imports:
  • package:magpie_cli/src/base/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 135 issues. Showing the first 2:

INFO: Avoid relative imports for files in `lib/`.

bin/mgpcli.dart:2:8

  ╷
2 │ import '../lib/executable.dart' as executable;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/mgpcli.dart

INFO: Use isEmpty instead of length

bin/mgpcli.dart:17:7

   ╷
17 │   if (args.length == 0) {
   │       ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/mgpcli.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.112.0.133.1.2
args^1.5.21.6.02.1.0
async^2.4.02.6.12.6.1
build_config^0.4.1+10.4.51.0.0
build_runner^1.7.21.11.12.0.2
completion^0.2.1+10.2.31.0.0
convert^2.1.12.1.13.0.0
coverage^0.13.3+10.13.111.0.2
crypto^2.1.32.1.53.0.1
dwds^0.7.90.7.911.0.2
file^5.1.05.2.16.1.0
glob^1.2.01.2.02.0.1
graphs^0.2.00.2.02.0.0
http^0.12.0+20.12.20.13.3
http_multi_server^2.0.52.2.03.0.1
intl^0.16.00.16.10.17.0
json_rpc_2^2.1.02.2.23.0.0
linter^0.1.1010.1.1291.4.0
logging^0.11.3+20.11.41.0.1
meta^1.1.81.3.01.3.0
multicast_dns^0.2.20.2.20.3.0
mustache^1.1.11.1.11.1.1
package_config^1.1.01.9.32.0.0
path^1.6.41.8.01.8.0
platform^2.2.12.2.13.0.0
plugin^0.2.0+30.2.0+30.2.0+3
pool^1.4.01.5.01.5.0
process^3.0.123.0.134.2.1
pub_semver^1.4.21.4.42.0.0
quiver^2.0.52.1.53.0.1
scratch_space^0.0.4+10.0.4+31.0.0
shelf^0.7.50.7.91.1.1
shelf_static^0.2.80.2.9+21.0.0
shelf_web_socket^0.2.30.2.4+11.0.1
stack_trace^1.9.31.10.01.10.0
stream_channel^2.0.02.1.02.1.0
test_api^0.2.110.2.200.4.0
usage^3.4.13.4.24.0.2
vm_service^1.2.01.2.06.2.0
vm_service_client^0.2.6+20.2.6+30.2.6+3
watcher^0.9.7+130.9.7+151.0.0
web_socket_channel^1.1.01.2.02.1.0
webkit_inspection_protocol^0.5.00.5.41.0.0
xml^3.5.03.7.05.1.0
yaml^2.2.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
analyzer-0.41.21.5.0
boolean_selector-2.1.02.1.0
browser_launcher-0.1.90.1.10
build-1.6.22.0.1
build_daemon-2.1.03.0.0
build_resolvers-1.5.32.0.1
build_runner_core-6.1.77.0.0
built_collection-4.3.25.0.0
built_value-6.7.18.0.5
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.3.00.3.0
code_builder-3.2.04.0.0
collection-1.15.01.15.0
dart_style-1.3.122.0.1
devtools-0.1.82.2.1
devtools_server-0.1.102.2.1
fixnum-0.10.111.0.0
http_parser-3.1.44.0.0
io-0.3.51.0.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
matcher-0.12.100.12.10
mime-1.0.01.0.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
package_resolver-1.0.101.0.10
pedantic-1.11.01.11.0
petitparser-3.1.04.1.0
pubspec_parse-0.1.81.0.0
shelf_proxy-0.1.0+71.0.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
sse-2.1.23.8.3
stream_transform-0.0.202.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 36 issues. Showing the first 2:

The constraint `^2.0.11` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.