macos_ui 2.0.7 copy "macos_ui: ^2.0.7" to clipboard
macos_ui: ^2.0.7 copied to clipboard

PlatformmacOS

Flutter widgets and themes implementing the current macOS design language.

828
likes
150/ 160
pub points
93%
popularity

We analyzed this package 34 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1262 out of 1357 API elements (93.0 %) have documentation comments.

Some symbols that are missing documentation: macos_ui.ColorX, macos_ui.DatePickerFieldElement, macos_ui.DatePickerFieldElement.DatePickerFieldElement, macos_ui.DatePickerFieldElement.element, macos_ui.DatePickerFieldElement.isSelected.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.
Package does not support platform `iOS`.

Because:

  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.
Package does not support platform `Windows`.

Because:

  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.
Package does not support platform `Linux`.

Because:

  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.
Package does not support platform `Web`.

Because:

  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'MaterialState' is deprecated and shouldn't be used. Use WidgetState instead. Moved to the Widgets layer to make code available outside of Material. This feature was deprecated after v3.19.0-0.3.pre.

lib/src/library.dart:32:9

   ╷
32 │         MaterialState;
   │         ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/library.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
appkit_ui_element_colors ^1.0.0 1.0.0 1.0.0
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
gradient_borders ^1.0.0 1.0.1 1.0.1
macos_window_utils ^1.2.0 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.