m4d_translate 0.1.6
m4d_translate: ^0.1.6 copied to clipboard

Material Design 4 Dart - Translate

0
likes
50/ 130
pub points
0%
popularity

We analyzed this package 19 hours ago, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:7:5

  ╷
7 │ <li><a href="http://m4d_translate.example.mikemitterer.at">m4d_translate.example.mikemitterer.at</a></li>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/m4d_translate/compare/v0.1...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 12 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:m4d_translate/m4d_translate.dart that imports:
  • package:m4d_core/m4d_core.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/m4d_translate.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/translate/MaterialTranslate.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_log_handler^1.0.01.1.61.1.6
l10n>=2.0.0 <3.0.02.0.192.0.19
logging>=0.11.3 <1.0.00.11.41.0.2
m4d_core>=0.2.0 <1.0.00.2.210.2.21
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.031.0.0
analyzer-0.39.172.8.0
ansicolor-1.1.12.0.1
args-1.6.02.3.0
async-2.8.22.8.2
build_cli_annotations-1.2.02.0.0
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
dart_style-1.3.62.2.0
file-5.2.16.1.2
glob-1.2.02.0.2
html-0.14.0+40.15.0
intl-0.15.80.17.0
intl_translation-0.17.10+10.17.10+1
js-0.6.30.6.3
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
optional-3.1.06.1.0+1
package_config-1.9.32.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
petitparser-3.1.04.4.0
platform_detect-1.4.02.0.0
pub_semver-1.4.42.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
where-4.4.08.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.11.3 <1.0.0` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.