m4d_flux 0.1.0
m4d_flux: ^0.1.0

Dart native js
Flutter Android iOS web

Material Design 4 Dart - Flux-Datastore

0
likes
80 / 110
pub points
30 %
popularity

We analyzed this package on Nov 27, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 75 API elements (36.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/flux/ActionBusImpl.dart:43:44

   ╷
43 │         return _actionbus ?? (_actionbus = new ActionBusImpl._internal());
   │                                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/flux/ActionBusImpl.dart

INFO: Unnecessary new keyword.

lib/flux/ActionBusImpl.dart:64:24

   ╷
64 │         _controller =  new StreamController<Action>.broadcast(onCancel: () => _controller = null);
   │                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/flux/ActionBusImpl.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_log_handler^1.0.01.1.61.1.6
logging>=0.11.3 <1.0.00.11.40.11.4
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.11.1.1
intl-0.16.10.16.1
path-1.7.01.7.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
30%
popularity

Material Design 4 Dart - Flux-Datastore

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

office@mikemitterer.at

License

Apache 2.0 (LICENSE)

Dependencies

console_log_handler, logging, validate

More

Packages that depend on m4d_flux