m4d_core 0.2.21
m4d_core: ^0.2.21

Dart js
Flutter web

Material Design 4 Dart

1
likes
65 / 110
pub points
32 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 2 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/m4d_core/compare/v0.2...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 99 out of 244 API elements (40.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:m4d_core/m4d_core.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 147 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/core/DomRenderer.dart:38:28

   ╷
38 │     final Logger _logger = new Logger('mdlapplication.DomRenderer');
   │                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/core/DomRenderer.dart

INFO: Avoid const keyword.

lib/core/DomRenderer.dart:40:52

   ╷
40 │     static const _RendererCssClasses _cssClasses = const _RendererCssClasses();
   │                                                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/core/DomRenderer.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_log_handler^1.0.01.1.61.1.6
l10n^2.0.02.0.192.0.19
logging>=0.11.3 <1.0.00.11.40.11.4
path^1.4.01.7.01.7.0
platform_detect^1.3.01.4.01.4.0
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.013.0.0
analyzer-0.39.170.41.0
ansicolor-1.1.11.1.1
async-2.4.22.4.2
build_cli_annotations-1.2.01.2.0
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.10
file-5.2.15.2.1
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
intl-0.15.80.16.1
intl_translation-0.17.10+10.17.10+1
js-0.6.20.6.2
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
optional-3.1.05.0.0+1
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
where-4.4.08.0.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs