location 6.0.1 copy "location: ^6.0.1" to clipboard
location: ^6.0.1 copied to clipboard

Cross-platform plugin for easy access to device's location in real-time.

2765
likes
140/ 140
pub points
100%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/Lyokone/flutterlocation/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

35 out of 36 API elements (97.2 %) have documentation comments.

Some symbols that are missing documentation: location.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:location/location.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:location/location.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:location/location.dart that imports:
  • package:location_platform_interface/location_platform_interface.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
location_platform_interface ^4.0.0 4.0.0 4.0.0
location_web ^5.0.0 5.0.1 5.0.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2765
likes
140
pub points
100%
popularity

Publisher

verified publisherbernos.dev

Cross-platform plugin for easy access to device's location in real-time.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, location_platform_interface, location_web

More

Packages that depend on location