locale_gen 3.4.0
locale_gen: ^3.4.0 copied to clipboard

Dart tool that will convert your default locale json to dart code.

3
likes
110 / 130
pub points
42 %
popularity

We analyzed this package on May 6, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 26 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:locale_gen/locale_gen.dart that imports:
  • package:locale_gen/src/locale_gen_writer.dart that imports:
  • package:locale_gen/src/locale_gen_params.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
intl^0.17.00.17.00.17.0
meta^1.3.01.3.01.3.0
path^1.8.01.8.01.8.0
yaml^3.1.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Dart 2.12.4.

3
likes
110
pub points
42%
popularity

Publisher

vanlooverenkoen.be

Dart tool that will convert your default locale json to dart code.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

intl, meta, path, yaml

More

Packages that depend on locale_gen