lnbits 1.0.1 copy "lnbits: ^1.0.1" to clipboard
lnbits: ^1.0.1 copied to clipboard

A Flutter package for interacting with the LNBits API. This package provides convenient methods to create, pay, check, and decode invoices, as well as getting wallet details.

1
likes
120/ 140
pub points
33%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 11 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: lnbits, lnbits.LNBitsAPI, lnbits.LNBitsAPI.LNBitsAPI, lnbits.LNBitsAPI.adminKey, lnbits.LNBitsAPI.checkInvoice.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

1
likes
120
pub points
33%
popularity

Publisher

verified publisherninjapay.me

A Flutter package for interacting with the LNBits API. This package provides convenient methods to create, pay, check, and decode invoices, as well as getting wallet details.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, http

More

Packages that depend on lnbits