livemap 0.6.0
livemap: ^0.6.0 copied to clipboard

Flutter Android iOS

A map widget with live position updates. Provides a controller to manage the map state.

11
likes
90 / 110
pub points
63 %
popularity

We analyzed this package on Mar 7, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 69 out of 70 API elements (98.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:livemap/livemap.dart that imports:
  • package:livemap/src/widgets/sidebar/sidebar.dart that imports:
  • package:livemap/src/widgets/sidebar/buttons.dart that imports:
  • package:livemap/src/controller.dart that imports:
  • package:livemap/src/marker.dart that imports:
  • package:flutter_map/flutter_map.dart that imports:
  • package:flutter_map/src/layer/tile_provider/mbtiles_image_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^0.1.20.1.31.0.2
device^0.1.10.1.10.2.0
extra_pedantic^1.1.1+31.3.01.3.0
flutterflutter0.0.00.0.0
flutter_map^0.8.20.8.20.11.0
fluttertoast^3.1.33.1.37.1.8
fluxmap^0.2.00.2.00.3.0
geopoint^0.7.00.7.10.8.0
geopoint_location^0.4.00.4.00.4.0
latlong^0.6.10.6.10.6.1
map_controller^0.6.10.6.10.9.0
pedantic^1.8.01.11.01.11.0
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.11.1.1
archive-2.0.133.1.2
args-1.6.02.0.0
async-2.5.02.5.0
cached_network_image-2.5.02.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
console_log_handler-1.1.61.1.6
convert-2.1.13.0.0
crypto-2.1.53.0.0
df-0.1.00.3.0
equatable-1.2.62.0.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-2.1.12.1.1
flutter_image-3.0.03.0.0
geodesy-0.3.20.3.2
geodf-0.1.10.2.0
geojson-0.8.00.10.0
geolocator-5.3.2+27.0.1
google_api_availability-2.0.43.0.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
image-2.1.193.0.1
injector-1.0.91.0.9
intl-0.16.10.17.0
iso-0.3.00.3.0
jiffy-2.2.04.0.0
location_permissions-3.0.0+13.0.0+1
logging-0.11.41.0.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
ml_linalg-12.17.1013.0.0
nested-1.0.01.0.0
octo_image-0.3.00.3.0
path-1.8.01.8.0
path_provider-1.6.272.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
petitparser-3.1.04.0.2
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
positioned_tap_detector-1.0.31.0.3
process-4.1.04.1.0
provider-4.3.35.0.0
quiver-2.1.53.0.0
rxdart-0.23.10.26.0
sky_engine-0.0.990.0.99
slugify2-0.2.10.2.1
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+2
sqflite_common-1.0.3+12.0.0+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
transparent_image-1.0.01.0.0
tuple-1.0.31.0.3
typed_data-1.3.01.3.0
uuid-2.2.23.0.1
validate-1.7.01.7.0
vector_math-2.1.02.1.0
win32-2.0.02.0.0
xdg_directories-0.1.20.2.0
xml-4.5.15.0.2
xrange-1.0.01.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions cupertino_icons to update the constraint.

The constraint `^0.1.1` on device does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions device to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

11
likes
90
pub points
63%
popularity

A map widget with live position updates. Provides a controller to manage the map state.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ansterj@gmail.com

License

MIT (LICENSE)

Dependencies

cupertino_icons, device, extra_pedantic, flutter, flutter_map, fluttertoast, fluxmap, geopoint, geopoint_location, latlong, map_controller, pedantic

More

Packages that depend on livemap