linkfive_purchases 1.5.0 copy "linkfive_purchases: ^1.5.0" to clipboard
linkfive_purchases: ^1.5.0 copied to clipboard

outdated

Manage your in-app subscriptions with the LinkFive plugin - The Easiest Implementation of Subscriptions.

17
likes
50/ 160
pub points
70%
popularity

We analyzed this package 3 days ago, and awarded it 50 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
Note: intl is pinned to version 0.19.0 by flutter_localizations from the flutter SDK.
See https://dart.dev/go/sdk-version-pinning for details.
failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: flutter pub get failed:
OUT:
Resolving dependencies...
ERR:
Note: intl is pinned to version 0.19.0 by flutter_localizations from the flutter SDK.
See https://dart.dev/go/sdk-version-pinning for details.


Because every version of in_app_purchases_intl depends on flutter_localizations from sdk which depends on intl 0.19.0, every version of in_app_purchases_intl requires intl 0.19.0.
So, because linkfive_purchases depends on in_app_purchases_intl ^0.0.3 which depends on intl ^0.17.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

flutter pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
Note: intl is pinned to version 0.19.0 by flutter_localizations from the flutter SDK.
See https://dart.dev/go/sdk-version-pinning for details.


Because every version of in_app_purchases_intl depends on flutter_localizations from sdk which depends on intl 0.19.0, every version of in_app_purchases_intl requires intl 0.19.0.
So, because linkfive_purchases depends on in_app_purchases_intl ^0.0.3 which depends on intl ^0.17.0, version solving failed.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.