linkcheck 2.0.19
linkcheck: ^2.0.19 copied to clipboard

A very fast link-checker. Crawls sites and checks integrity of links both in HTML and in CSS.

7
likes
95 / 130
pub points
61 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 95 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:34:43

   ╷
34 │ <p><code>linkcheck</code> finds more than <a href="http://www.linklint.org/">linklint</a> and 
   │                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 98 API elements (29.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:linkcheck/linkcheck.dart that imports:
  • package:linkcheck/src/destination.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args>=1.5.1 <3.0.02.1.12.1.1
console^4.1.04.1.04.1.0
csslib^0.17.00.17.00.17.0
glob^2.0.12.0.12.0.1
html^0.15.00.15.00.15.0
logging^1.0.11.0.11.0.1
path^1.6.21.8.01.8.0
source_span^1.5.51.8.11.8.1
stream_channel^2.0.02.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
file-6.1.26.1.2
meta-1.4.01.4.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.11.99 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

7
likes
95
pub points
61%
popularity

Publisher

filiph.net

A very fast link-checker. Crawls sites and checks integrity of links both in HTML and in CSS.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, console, csslib, glob, html, logging, path, source_span, stream_channel

More

Packages that depend on linkcheck