less_dart 2.3.8
less_dart: ^2.3.8 copied to clipboard

Dart native

Native Dart Less compiler/builder to generate .css files from .less sources.

1
likes
90 / 110
pub points
57 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1153 out of 2251 API elements (51.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:less_dart/less.dart that imports:
  • package:less_dart/src/visitor/visitor_base.dart that imports:
  • package:less_dart/src/tree/tree.dart that imports:
  • package:less_dart/src/plugins/less_plugin_clean_css/less_plugin_clean_css.dart that imports:
  • package:less_dart/src/plugins/plugins.dart that imports:
  • package:less_dart/src/less_options.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/src/functions/svg_functions.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/tree/at_rule.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build>=1.0.0 <2.0.01.6.21.6.3
build_config>=0.3.1 <0.5.00.4.60.4.6
meta>=1.0.4 <2.0.01.2.41.3.0
mime>=0.9.0 <0.12.00.9.71.0.0
package_resolver>=1.0.2 <2.0.01.0.101.0.10
path>=1.4.1 <2.0.01.7.01.8.0
source_maps>=0.10.2 <0.12.00.10.90.10.10
source_span>=1.4.0 <2.0.01.7.01.8.1
utf>=0.9.0 <0.12.00.9.0+50.9.0+5
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
analyzer-0.41.21.1.0
args-1.6.02.0.0
async-2.4.22.5.0
charcode-1.1.31.2.0
checked_yaml-1.0.42.0.0
cli_util-0.2.00.3.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
file-5.2.16.1.0
glob-1.2.02.0.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
js-0.6.20.6.3
json_annotation-3.1.14.0.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.80.1.8
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.9.0 <0.12.0` on mime does not support the stable version `1.0.0`, that was published 24 days ago.

When mime is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions mime to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

1
likes
90
pub points
57%
popularity

Native Dart Less compiler/builder to generate .css files from .less sources.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

adalberto.lacruz@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

build, build_config, meta, mime, package_resolver, path, source_maps, source_span, utf

More

Packages that depend on less_dart