package_resolver 1.0.10

  • Readme
  • Changelog
  • Installing
  • 49

A package that defines a common class, PackageResolver, for defining how to resolve package: URIs. This class may be based on the current isolate's package resolution strategy, but it may also be explicitly defined by the user—for example, you could create a resolver that represents the strategy used to compile a .dart.js file.

The Dart VM provides two mutually exclusive means of resolving package: URIs: a package spec and a package root.

  • A package spec usually comes in the form of a .packages file on the filesystem. It defines an individual root URL for each package name, so that package:$name/$path resolves to $root/$path.

  • A package root is a single URL that acts as the base for all package: URIs, so that package:$name/$path resolves to $base/$name/$path.

This normalizes access to these resolution schemes, and makes it easy for code to resolve package URIs no matter where the resolution information comes from.

1.0.10 #

  • Use conditional imports to avoid dart:isolate imports on the web.
  • Bump minimum SDK to 2.1.0.

1.0.9 #

  • Identical to 1.0.6 - republishing with a higher version number to get around issues with conditional dart:isolate imports on the version of build_modules which is compatible with the 2.0.0 SDK.

1.0.8 #

  • Fix issue on Dart 2.0.0.

1.0.7 #

  • Use conditional imports to avoid dart:isolate imports on the web.

1.0.6 #

  • Support package:http version 0.12.x.

1.0.5 #

  • Use conditional imports to avoid dart:io imports on the web.

1.0.4 #

  • Set max SDK version to <3.0.0, and adjust other dependencies.

1.0.3 #

  • Update SDK version.
  • Stop using deprecated UTF8 constant.

1.0.2 #

  • Don't crash on URIs without path components.

1.0.1 #

  • Internal changes only.

1.0.0 #

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  package_resolver: ^1.0.10

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:package_resolver/package_resolver.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
97
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

This package is not analyzed, because it is discontinued.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0