utf 0.9.0+5

  • Readme
  • Changelog
  • Installing
  • 74

Provides common operations for manipulating Unicode sequences.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.9.0+5 #

  • Set max SDK version to <3.0.0, and adjust other dependencies.

0.9.0+4 #

  • Updates to support Dart 2.0 core library changes (wave 2.2). Package now requires Dart 2.0.0-dev.20.0. See issue 31847 for details.

0.9.0+3 #

  • Code cleanup.

0.9.0+2 #

  • ChangeLog starts here.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  utf: ^0.9.0+5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:utf/utf.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
17
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Fix lib/src/utf16.dart. (-18.98 points)

Analysis of lib/src/utf16.dart reported 42 hints, including:

line 14 col 1: Prefer using /// for doc comments.

line 21 col 10: Unnecessary new keyword.

line 24 col 1: Prefer using /// for doc comments.

line 36 col 10: Unnecessary new keyword.

line 37 col 13: Unnecessary new keyword.

Fix lib/src/utf32.dart. (-17.34 points)

Analysis of lib/src/utf32.dart reported 38 hints, including:

line 13 col 1: Prefer using /// for doc comments.

line 24 col 10: Unnecessary new keyword.

line 25 col 13: Unnecessary new keyword.

line 28 col 1: Prefer using /// for doc comments.

line 40 col 10: Unnecessary new keyword.

Fix lib/src/utf8.dart. (-9.99 points)

Analysis of lib/src/utf8.dart reported 21 hints, including:

line 32 col 1: Prefer using /// for doc comments.

line 41 col 10: Unnecessary new keyword.

line 44 col 1: Prefer using /// for doc comments.

line 55 col 10: Unnecessary new keyword.

line 56 col 8: Unnecessary new keyword.

Fix additional 7 files with analysis or formatting issues. (-17.19 points)

Additional issues in the following files:

  • lib/src/utf_stream.dart (12 hints)
  • lib/src/util.dart (9 hints)
  • lib/src/list_range.dart (6 hints)
  • lib/src/utf_16_code_unit_decoder.dart (5 hints)
  • lib/src/constants.dart (1 hint)
  • lib/src/shared.dart (1 hint)
  • lib/utf.dart (1 hint)

Maintenance suggestions

Package is getting outdated. (-72.88 points)

The package was last published 90 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and utf.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.20.0 <3.0.0
Dev dependencies
test ^1.2.0