learning_entity_extraction 0.0.3 copy "learning_entity_extraction: ^0.0.3" to clipboard
learning_entity_extraction: ^0.0.3 copied to clipboard

The easy way to use ML Kit for entity extraction in Flutter.

5
likes
130/ 140
pub points
46%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 29 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: learning_entity_extraction, learning_entity_extraction.ARABIC, learning_entity_extraction.CHINESE, learning_entity_extraction.DUTCH, learning_entity_extraction.ENGLISH.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:learning_entity_extraction/learning_entity_extraction.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:learning_entity_extraction/learning_entity_extraction.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:learning_entity_extraction/learning_entity_extraction.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:learning_entity_extraction/learning_entity_extraction.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

5
likes
130
pub points
46%
popularity

Publisher

unverified uploader

The easy way to use ML Kit for entity extraction in Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on learning_entity_extraction