leancode_localization 0.0.5

Flutter Android iOS

Localization helpers for multi-language apps

1
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 61 API elements (13.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:leancode_localization/leancode_localization.dart that imports:
  • package:leancode_localization/src/storages/shared_prefs_locale_storage.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:leancode_localization/leancode_localization.dart that imports:
  • package:leancode_localization/src/storages/shared_prefs_locale_storage.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web
Package does not support Flutter platform Linux

Because:

  • package:leancode_localization/leancode_localization.dart that imports:
  • package:leancode_localization/src/storages/shared_prefs_locale_storage.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:leancode_localization/leancode_localization.dart that imports:
  • package:leancode_localization/src/storages/shared_prefs_locale_storage.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:leancode_localization/leancode_localization.dart that imports:
  • package:leancode_localization/src/storages/shared_prefs_locale_storage.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:leancode_localization/leancode_localization.dart that imports:
  • package:leancode_localization/src/storages/shared_prefs_locale_storage.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.111.15.0-nullsafety.31.15.0-nullsafety.4
devicelocale^0.2.00.2.30.3.3
flutterflutter0.0.00.0.0
leancode_common^0.1.00.1.00.1.0
leancode_common_flutter^0.1.00.1.10.1.1
meta^1.1.21.3.0-nullsafety.31.3.0-nullsafety.5
provider^3.0.03.2.04.3.2+2
rxdart^0.22.00.22.60.24.1
shared_preferences^0.5.00.5.12+20.5.12+2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0-nullsafety.2
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.16.1
path-1.7.01.8.0-nullsafety.2
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.2.0` on devicelocale does not support the latest published version `0.3.3`

pubspec.yaml:15:17

   ╷
15 │   devicelocale: ^0.2.0
   │                 ^^^^^^
   ╵
The constraint `^3.0.0` on provider does not support the latest published version `4.3.2+2`

pubspec.yaml:17:13

   ╷
17 │   provider: ^3.0.0
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs