leancode_common_flutter 0.1.1

  • Readme
  • Changelog
  • Installing
  • 63

leancode_common_flutter #

Common classes which depend on Flutter used together with leancode_common library.

Available classes:

  • LifecycleMethodsInvoker
  • ValuePublishSubject

Changelog #

[0.1.1] - 23.10.2019

  • Divide LifecycleMethodProvider into separate widgets per lifecycle method

[0.1.0] - 23.10.2019

  • Remove provider class
  • Increase version to correspond with leancode_common

[0.0.2] - 16.10.2019

  • Fix ValuePublishSubject hasValue being always true

[0.0.1] - 19.03.2019

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  leancode_common_flutter: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:leancode_common_flutter/leancode_common_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
74
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/src/lifecycle_methods_invoker.dart. (-1 points)

Analysis of lib/src/lifecycle_methods_invoker.dart reported 2 hints:

line 25 col 51: 'LifecycleMethodsInvoker' is deprecated and shouldn't be used.

line 50 col 24: 'LifecycleMethodsInvoker' is deprecated and shouldn't be used.

Fix lib/src/value_publish_subject.dart. (-0.50 points)

Analysis of lib/src/value_publish_subject.dart reported 1 hint:

line 8 col 11: Close instances of dart.core.Sink.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and leancode_common_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-6 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
async ^2.3.0 2.4.0
flutter 0.0.0
leancode_common ^0.1.0 0.1.0
rxdart ^0.22.0 0.22.6 0.23.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
test_api any