laksadart 0.2.1+1
laksadart: ^0.2.1+1 copied to clipboard

Dart library for Zilliqa's Blockchain, including Schnorr, wallet/account/keys manager, RPCMethod, Transactions and Contracts deploy/call.

1
likes
90/ 130
pub points
0%
popularity

We analyzed this package 28 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 62 out of 721 API elements (8.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:laksadart/laksadart.dart that imports:
  • package:laksadart/src/crypto/index.dart that imports:
  • package:laksadart/src/crypto/isolates.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/proto/message.pb.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bech32^0.2.00.2.10.2.1
bip32^2.0.02.0.02.0.0
bip39^1.0.61.0.61.0.6
collection^1.15.01.15.01.15.0
convert^3.0.03.0.13.0.1
crypto^3.0.13.0.13.0.1
fixnum^1.0.01.0.01.0.0
freezed_annotation^0.14.20.14.31.0.0
http^0.13.30.13.40.13.4
meta^1.3.01.7.01.7.0
pointycastle^3.0.13.4.03.4.0
protobuf^2.0.02.0.12.0.1
source_helper^1.2.11.3.01.3.0
tuple^2.0.02.0.02.0.0
uuid^3.0.43.0.53.0.5
validators^3.0.03.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.031.0.0
analyzer-2.8.02.8.0
args-2.3.02.3.0
async-2.8.22.8.2
bs58check-1.0.21.0.2
build-2.1.12.1.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
dart_style-2.2.02.2.0
file-6.1.26.1.2
glob-2.0.22.0.2
hex-0.2.00.2.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.4.04.4.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
package_config-2.0.22.0.2
path-1.8.01.8.0
pub_semver-2.1.02.1.0
quiver-3.0.1+13.0.1+1
source_gen-1.2.01.2.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.2` on freezed_annotation does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

1
likes
90
pub points
0%
popularity

Dart library for Zilliqa's Blockchain, including Schnorr, wallet/account/keys manager, RPCMethod, Transactions and Contracts deploy/call.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bech32, bip32, bip39, collection, convert, crypto, fixnum, freezed_annotation, http, meta, pointycastle, protobuf, source_helper, tuple, uuid, validators

More

Packages that depend on laksadart