lakos 2.0.2 icon indicating copy to clipboard operation
lakos: ^2.0.2 copied to clipboard

Visualize internal Dart library dependencies in Graphviz dot. Detect dependency cycles.

60
likes
120/ 130
pub points
57%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 87 out of 96 API elements (90.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:lakos/lakos.dart that imports:
  • package:lakos/src/build_model.dart that imports:
  • package:lakos/src/compute_metrics.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args2.3.02.3.02.3.1
darq1.1.11.1.11.2.1
directed_graph0.3.60.3.60.3.7
glob2.0.22.0.22.1.0
path1.8.11.8.11.8.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
collection-1.16.01.16.0
exception_templates-0.2.10.2.1
file-6.1.26.1.2
graphs-2.1.02.1.0
lazy_memo-0.1.20.1.2
meta-1.8.01.8.0
quote_buffer-0.2.30.2.3
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `2.3.0` on args does not support the stable version `2.3.1`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `1.1.1` on darq does not support the stable version `1.2.0`.

Try running dart pub upgrade --major-versions darq to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Dart 2.17.5.

60
likes
120
pub points
57%
popularity

Publisher

verified publisher iconolegalexander.com

Visualize internal Dart library dependencies in Graphviz dot. Detect dependency cycles.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

args, darq, directed_graph, glob, path

More

Packages that depend on lakos