kuzzle 2.1.0
kuzzle: ^2.1.0 copied to clipboard

Dart native
Flutter Android iOS

A library to interact with kuzzle API. A backend software, self-hostable and ready to use to power modern cross-platform apps.

14
likes
80 / 110
pub points
51 %
popularity

We analyzed this package on Jan 22, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 143 out of 411 API elements (34.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:kuzzle/kuzzle.dart that imports:
  • package:kuzzle/src/protocols/websocket.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

INFO: Unnecessary cast.

lib/src/controllers/document.dart:109:12

    ╷
109 │       return List<String>.from(
    │ ┌────────────^
110 │ │       response.result['ids'] as List<dynamic>
111 │ │     ) as List<String>;
    │ └─────────────────────^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/controllers/document.dart

INFO: 'List' is deprecated and shouldn't be used.

lib/src/kuzzle.dart:156:34

    ╷
156 │   final List<String> _requests = List();
    │                                  ^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/kuzzle.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.81.2.41.2.4
pedantic^1.9.01.9.21.9.2
uuid^2.0.42.2.22.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

14
likes
80
pub points
51%
popularity

Publisher

kuzzle.io

A library to interact with kuzzle API. A backend software, self-hostable and ready to use to power modern cross-platform apps.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta, pedantic, uuid

More

Packages that depend on kuzzle