kurdish_sorani_tools 0.0.9 copy "kurdish_sorani_tools: ^0.0.9" to clipboard
kurdish_sorani_tools: ^0.0.9 copied to clipboard

تایبەتمەندی جیاواز لەخۆدەگرێت بۆ زمانی شیرینی کوردی

7
likes
135/ 160
pub points
52%
popularity

We analyzed this package 3 days ago, and awarded it 135 pub points (of a possible 160):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: kurdish_sorani_tools,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: kurdish_sorani_tools.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 53 API elements (43.4 %) have documentation comments.

Some symbols that are missing documentation: kurdish_sorani_tools, kurdish_sorani_tools.CommasNum, kurdish_sorani_tools.CommasNum.ZyadkrdnyFariza, kurdish_sorani_tools.CommasString, kurdish_sorani_tools.CommasString.LabrdnyFariza.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

INFO: The variable name 'DananyFariza' isn't a lowerCamelCase identifier.

lib/src/core/commas/commas.dart:7:8

  ╷
7 │ String DananyFariza(Object number) {
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/core/commas/commas.dart

INFO: The variable name 'SrinawayFariza' isn't a lowerCamelCase identifier.

lib/src/core/commas/commas.dart:31:5

   ╷
31 │ num SrinawayFariza(String number) {
   │     ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/core/commas/commas.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

7
likes
135
pub points
52%
popularity

Publisher

unverified uploader

تایبەتمەندی جیاواز لەخۆدەگرێت بۆ زمانی شیرینی کوردی

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on kurdish_sorani_tools