koyo 0.5.0 copy "koyo: ^0.5.0" to clipboard
koyo: ^0.5.0 copied to clipboard

A Flutter utility library that enables faster development and less boilerplate for specific use cases.

2
likes
110/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/timosg/koyo/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

17 out of 70 API elements (24.3 %) have documentation comments.

Some symbols that are missing documentation: koyo, koyo.JsonArray, koyo.JsonObject, koyo.Koyo, koyo.Koyo.Koyo.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:koyo/koyo.dart that imports:
  • package:koyo/src/widgets.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:koyo/koyo.dart that imports:
  • package:koyo/src/core.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:koyo/koyo.dart that imports:
  • package:koyo/src/core.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:koyo/koyo.dart that imports:
  • package:koyo/src/core.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:koyo/koyo.dart that imports:
  • package:koyo/src/core.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/styles/ky_radius.dart:3:1

  ╷
3 │ part of core;
  │ ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/styles/ky_radius.dart

INFO: The part-of directive uses a library name.

lib/src/styles/ky_shadows.dart:1:1

  ╷
1 │ part of core;
  │ ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/styles/ky_shadows.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus ^8.0.0 8.2.2 10.1.0
flutter flutter 0.0.0 0.0.0
internet_connection_checker_plus ^1.0.1 1.0.1 2.3.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 4.1.4 5.4.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^8.0.0` on device_info_plus does not support the stable version `9.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^1.0.1` on internet_connection_checker_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions internet_connection_checker_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2
likes
110
pub points
0%
popularity

Publisher

verified publisherwydget.de

A Flutter utility library that enables faster development and less boilerplate for specific use cases.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

device_info_plus, flutter, internet_connection_checker_plus

More

Packages that depend on koyo